Excel 2 Listen vergleichen und gleiche Daten natlos anhängen

Nützliche Programme zu Zeiterfassung, Dokumentenmanagement etc.
Antworten
Bene
PLUS-Mitglied
PLUS-Mitglied
Beiträge: 851
Registriert: 12. Apr 2015 13:31

Excel 2 Listen vergleichen und gleiche Daten natlos anhängen

Hallo Leute

Ich hoffe Ihr könnt mir helfen.
Habe gerade ein kleines Problem.

Ich muss gerade 2 Tabelen miteinander vergleichen.

In Tabelle 1 steht nur die Artikelnummer in Feld A.
Also:
A
1
2
3
4
5
6
7

In Tabelle 2 Steht die Artikelnummer mehrfach mit weiteren Daten.
A B
1 Der
1 Paul
1 geht
1 stiften weil
1 er angs hat
2 Karl
2 kann
2 nicht
2 lesen
3 Ute
3 hinkt
4 Peter
4 mag
4 Tomaten

In Tabelle eins sollten nun in Feld B alle Werte aus Tabelle 2 integriert werden. Die Reihenfolge wäre sogar egal.

Also das Ergebnis.
Tabelle1:
A B
1 Paul geht stiften weil er Angst hat
2 Karl kann nicht lesen
3 Ute hinkt
4 Peter mag Tomaten

Ich komme leider nicht drauf wie man das anstellen könnte.
Da Tabelle 2 ca. 10.000 Zeilen hat ist es Händisch eine Qual. :-(

Hoffe jemand hätte da eine Lösung für mich.

Mfg B.


Benutzeravatar
Xantiva
PLUS-Mitglied
PLUS-Mitglied
Beiträge: 3946
Registriert: 22. Okt 2010 17:52
Land: Deutschland
Firmenname: Xantiva.de
Branche: Entwickler, aber auch selber Seller!
Kontaktdaten:

Re: Excel 2 Listen vergleichen und gleiche Daten natlos anhä

Das geht nicht in einem Rutsch. Ich würde folgendes machen ...
  • Füge an die Tabelle B zwei neue Spalten an.
  • In C2 bis unten fügst Du folgende Formel ein: =WENN(A1=A2;VERKETTEN(C1;" ";B2);B2)
  • In D2 bis unten fügst Du folgende Formel ein: =WENN(A3=A2;FALSCH;WAHR)
Dann nimmst Du Dir alle Zeilen, in denen D Wahr ist ... ;)
sellerforum-excel-hilfe.PNG
sellerforum-excel-hilfe.PNG (20.03 KiB) 1203 mal betrachtet
qds1
Beiträge: 553
Registriert: 30. Jun 2016 18:51

Re: Excel 2 Listen vergleichen und gleiche Daten natlos anhä

Moin,

mit einem VBA Script ginge das in einem Rutsch. Sendest du mir die Dateien, mache ich dir das gern fertig für kleines Geld. Schreibe mich gern an.
Benutzeravatar
Xantiva
PLUS-Mitglied
PLUS-Mitglied
Beiträge: 3946
Registriert: 22. Okt 2010 17:52
Land: Deutschland
Firmenname: Xantiva.de
Branche: Entwickler, aber auch selber Seller!
Kontaktdaten:

Re: Excel 2 Listen vergleichen und gleiche Daten natlos anhä

... für kleines Geld ...

gibt es hier auch eine Plus-Mitgliedschaft. :konfuzius:
qds1
Beiträge: 553
Registriert: 30. Jun 2016 18:51

Re: Excel 2 Listen vergleichen und gleiche Daten natlos anhä

Du hast recht, aber ich habe nirgendwo in den Regeln gefunden, dass man seine Hilfe nur als Plus Mitglied anbieten darf...
Benutzeravatar
Xantiva
PLUS-Mitglied
PLUS-Mitglied
Beiträge: 3946
Registriert: 22. Okt 2010 17:52
Land: Deutschland
Firmenname: Xantiva.de
Branche: Entwickler, aber auch selber Seller!
Kontaktdaten:

Re: Excel 2 Listen vergleichen und gleiche Daten natlos anhä

Den Spruch lese ich irgendwie im Forum hier in letzter Zeit immer wieder (ich weiß gar nicht, ob immer von Dir).


Für kleines Geld (Plus) könntest Du Dir z. B. die ganzen rechtlichen Informationen und Tipps durchlesen. Dann wäre Dir evtl. auch bewusst, dass Du kein vollständiges Impressum auf deiner Webseite hast. :winken: engel
Bene
PLUS-Mitglied
PLUS-Mitglied
Beiträge: 851
Registriert: 12. Apr 2015 13:31

Re: Excel 2 Listen vergleichen und gleiche Daten natlos anhä

Guten Morgen

Vielen Dank Xantiva!!!!!

Das Funktioniert einwandfrei juhu
Ich habe da gestern den ganzen Nachmittag gesessen.
Und deine Lösung ist total simpel gewesen.
Auf diese Idee wäre ich im Leben nicht gekommen. :roll:

Ich persönlich habe jetzt auch kein Problem damit für solche Sachen ein Entgeld zu bezahlen.
Wenn ich dran denke wie viel Zeit ich gestern investiert habe und zu keiner Lösung gekommen bin.

Tabellen bearbeiten und sortieren kommt ja immer öfter vor.

Mfg B.
Benutzeravatar
Xantiva
PLUS-Mitglied
PLUS-Mitglied
Beiträge: 3946
Registriert: 22. Okt 2010 17:52
Land: Deutschland
Firmenname: Xantiva.de
Branche: Entwickler, aber auch selber Seller!
Kontaktdaten:

Re: Excel 2 Listen vergleichen und gleiche Daten natlos anhä

Bene hat geschrieben:Und deine Lösung ist total simpel gewesen.
Tagesgeschäft eines Entwicklers: Komplexe Aufgaben in kleine Teilaufgaben aufspalten, die dann plötzlich einfach werden. :-}
Benutzeravatar
fonprofi
PLUS-Mitglied
PLUS-Mitglied
Beiträge: 6589
Registriert: 17. Nov 2010 16:43
Land: Deutschland

Re: Excel 2 Listen vergleichen und gleiche Daten natlos anhä

Xantiva hat geschrieben:Dir evtl. auch bewusst, dass Du kein vollständiges Impressum auf deiner Webseite hast. :winken: engel
Ich kann mit dem Tablet gar kein Impressum sehen...
qds1
Beiträge: 553
Registriert: 30. Jun 2016 18:51

Re: Excel 2 Listen vergleichen und gleiche Daten natlos anhä

dass Du kein vollständiges Impressum auf deiner Webseite hast.
Ist mir bewusst und in Arbeit. Habe das Nebengewerbe erst seit ein Paar Monaten und die Seite seit ein paar Wochen.
Danke für die Erinnerung an die Dringlichkeit. Auch damit hast du recht. :daumenhoch:
Den Spruch lese ich irgendwie im Forum hier in letzter Zeit immer wieder
Ist das verwerflich? :shock:

Aber nun gut, ist alles off topic. OP hat ja das Problem bereits gelöst...
Benutzeravatar
Xantiva
PLUS-Mitglied
PLUS-Mitglied
Beiträge: 3946
Registriert: 22. Okt 2010 17:52
Land: Deutschland
Firmenname: Xantiva.de
Branche: Entwickler, aber auch selber Seller!
Kontaktdaten:

Re: Excel 2 Listen vergleichen und gleiche Daten natlos anhä

qds1 hat geschrieben:Ist das verwerflich? :shock:
http://www.sellerforum.de/seller-plus.php
Stichwort: "Produkte / Dienstleistungen anbieten"

Mit der Plus-Mitgliedschaft nicht mehr ...
qds1
Beiträge: 553
Registriert: 30. Jun 2016 18:51

Re: Excel 2 Listen vergleichen und gleiche Daten natlos anhä

Danke, werde ich beherzigen saufen
Impressum habe ich provisorisch erstmal verlinkt.
Antworten

Zurück zu „Office-Programme & Tools“

  • Information